qzgx.net
当前位置:首页 >> EClipsE编译不运行 >>

EClipsE编译不运行

在eclipse的菜单有一个project--->bulid automatically,如果本选中就会自动编译不选中就不会自动编译

问题描述:最近使用eclipse运行java程序时,发现只能编译程序,但是无法运行java程序,查了好多资料,都没能解决这个问题,今天终于解决了,,,终于知道问题之所在!开始我检查了jdk版本,编译版本和运行时版本,都是一致的,并没有

另一种就是你的JDK版本问题,如果你以前用的1.4 换成这个机子上的1.5编译不会有变化,但是执行没问题, 换下包就行了.

Workspace有毛病,仔细核对一下workspace中文件.

可能是.java文件没有自动编译出.class文件,手动clean一下,或者看下javaw.jar有没有被引用

起初你或许会认为是一个莫名其妙的错误,因为代码根本一点问题的都没有,可运行期间总是报这个错,比较郁闷. 出现Could not find the main class.program will exit和java.lang.UnsupportedClassVersionError 错误的原因,是因为我们使用高版

首先确定jdk和自己的系统一致 X86对应32 X64对应64在 此次下载 win7环境变量配置 (Xp等系统略有不同)1.右键计算机 > 属性 > 左边的“高级系统设置” > “高级”选项卡 > 下面“环境变量”系统环境变量 变量名 值 classpath 点分

eclipse 是最好又最郁闷的工具. 导入后一般需要clean,然后就会生成gen目录和相应的R.java文件.如果不行,项目上面点右键打开属性,左边选android,右边是否有打勾其中一个.没有就打上.再不行,那就eclipse升级到最新版,sdk升级到最新版.

如果你的代码中有包相关的语句的话 你的代码文件必须包含在包中才行 否者运行环境是找不到你的程序的

从字面理解是抽象方法错误 也就是程序代码肯定有问题 在看看你的jdk真的配置好了吗 配置好了肯定不会有问题

网站首页 | 网站地图
All rights reserved Powered by www.qzgx.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com